Crashes in mobile app
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Jul 14, 2023 - 17:21 UTC
Investigating
We've spotted crashes in mobile app that happen sporadically. We're currently investigating the issue, and will provide an update soon.
Posted Jul 14, 2023 - 16:30 UTC
This incident affected: 📱 Mobile application.