Pleo web page blank
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 20:57 UTC
Update
There is currently an issue with Pleo's web page where it stays blank.
There is also an issue getting the card details in the APP.
The issue has been identified and we are working on a fix.
Posted Mar 17, 2021 - 20:33 UTC
Identified
There is currently an issue with Pleo's web page where it stays blank. The issue has been identified and we are working on a fix.
Posted Mar 17, 2021 - 20:12 UTC
This incident affected: 📱 Mobile application and Card.