This incident has now been fully resolved.
Incident Report for Pleo
Resolved
The incident has been resolved and we apologise for any inconvenience this has caused.
Have a lovely day!
Posted Oct 02, 2023 - 15:01 UTC
Monitoring
We have now deployed changes that should resolve this issue. We are now actively monitoring to make sure everything works as expected.
Posted Oct 02, 2023 - 14:40 UTC
Investigating
We continue to investigate this issue and hope to identify and solve the underlying issue shortly. We will keep this page up to date.
Posted Oct 02, 2023 - 13:40 UTC
Monitoring
We are actively resolving this issue.
We apologize for any inconvenience this might have caused.
Another update will follow shortly once we verify the solution.
Posted Oct 02, 2023 - 12:07 UTC
Investigating
We've spotted that something has gone wrong and we are experiencing performance issues. We're currently investigating the issue, and will provide an update soon.
Posted Oct 02, 2023 - 11:29 UTC