Dinero is experiencing performance issues
Incident Report for Pleo
Resolved
Dinero performance issues has been resolved.
Posted Mar 15, 2022 - 18:29 UTC
Investigating
We are currently investigating the issue
Posted Mar 15, 2022 - 09:41 UTC
This incident affected: 🛠 Integrations (Dinero).