Transaction not coming through
Incident Report for Pleo
Resolved
Our partner managed to resolve the underlying issue.

Sorry again and thanks for you patience!
Posted 4 months ago. Feb 23, 2019 - 15:19 CET
Update
Our partner managed to resolve the underlying issue.

Sorry again and thanks for you patience!
Posted 4 months ago. Feb 23, 2019 - 15:18 CET
Update
We are continuing to investigate this issue.
Posted 4 months ago. Feb 23, 2019 - 15:17 CET
Update
Our transaction partner is experiencing issues.

We're investigating the issue with our partner and will update you as soon as we know more.

Sorry for the inconvenience.
Posted 4 months ago. Feb 23, 2019 - 15:09 CET
Investigating
Transactions are not coming through. We are investigating
Posted 4 months ago. Feb 23, 2019 - 14:50 CET
This incident affected: 💳 Transactions.