Manual UK transfers may be delayed
Resolved·Degraded performance

We think the impact from the issue is over.

Mon, Jan 8, 2024, 09:52 AM
(1 year ago)
·
Affected components
💰 Wallet
Updates

Resolved

We think the impact from the issue is over.

Mon, Jan 8, 2024, 09:52 AM

Investigating

We've spotted that some manual transfers from UK bank accounts are currently delayed. We are investigating this at the moment and appreciate your patience.

Sun, Jan 7, 2024, 11:54 AM(21 hours earlier)
Powered by