Wallet load incident
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted May 11, 2022 - 12:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2022 - 11:35 UTC
Update
We are currently experiencing issues with certain pleo functionalities incl. wallet loads, pocket reimbursements, bill payments, activating cards and viewing card details. We are investigating the issue together with our partners and will keep you posted as soon as possible. Sorry for the inconvenience.
Posted May 11, 2022 - 10:20 UTC
Update
We are currently experiencing issues with some of functionality incl. wallet loads, activating cards and viewing card details. We are investigating the issue together with our partners and will keep you posted as soon as possible. Sorry for the inconvenience.
Posted May 11, 2022 - 09:34 UTC
Investigating
We are currently experiencing issues with some of our wallet loads. We're investigating the issue and will keep you posted as soon as possible. Sorry for the inconvenience.
Posted May 11, 2022 - 08:51 UTC
This incident affected: 📱 Mobile application, 💰 Wallet, Card, Reimbursements, and Invoices.