Card transactions impacted
Incident Report for Pleo
Resolved
We have completed our investigation of the irregular issues with the transaction processing engine and have resolved them. It is now possible to use virtual cards and Apple/Google Pay again. Thank you for your patience and understanding as we have worked on this issue!
Posted Jul 25, 2022 - 12:58 UTC
Update
We continue to Experience issues with our transaction processing. We continue to decline transactions with Apple/Google pay.
Transactions with Virtual cards will be declined outright. However transactions with physical cards will now be possible online.
We apologise for any inconvenience this may cause and will keep you updated as we work to resolve this as quickly as we can.
Posted Jul 25, 2022 - 10:39 UTC
Update
We are still investigating irregular issues with virtual cards. We continue to decline transactions with Apple/Google pay.
Transactions with Virtual cards will be declined outright. However transactions with physical cards will now be possible online.
Transactions in Ukraine will again be possible.
We apologise for any inconvenience this may cause and will keep you updated as we work to resolve this as quickly as we can.
Posted Jul 24, 2022 - 11:17 UTC
Update
We are continuing to investigate this issue.
Posted Jul 24, 2022 - 11:11 UTC
Update
We are still investigating irregular issues with virtual cards. We continue to decline transactions with Apple/Google pay.
Transactions with Virtual cards will be declined outright. However transactions with physical cards will now be possible online.
Transactions in Ukraine will again be possible.
We apologise for any inconvenience this may cause and will keep you updated as we work to resolve this as quickly as we can.
Posted Jul 23, 2022 - 21:33 UTC
Update
We are still investigating irregular issues with virtual cards. You can use your physical card for in-store and online spend. Virtual cards and Apple/Google Pay are currently unavailable. We apologise for any inconvenience this may cause and will keep you updated as we work to resolve this as quickly as we can.
Posted Jul 23, 2022 - 20:40 UTC
Update
We are still investigating irregular issues with our transaction processing engine. You can use your physical card for in-store spend. Online spend with virtual & physical cards and Apple/Google Pay is currently unavailable. We apologise for any inconvenience this may cause and will keep you updated here.
Posted Jul 23, 2022 - 17:53 UTC
Update
We are experiencing irregular issues with our transaction processing engine and are investigating. You can use your physical card for in-store spend. Online spend with virtual & physical cards and Apple/Google Pay is currently unavailable. We apologise for any inconvenience this may cause and will keep you updated here.
Posted Jul 23, 2022 - 12:07 UTC
Update
We are continuing to investigate this issue.
Posted Jul 23, 2022 - 11:03 UTC
Investigating
We are experiencing issues with our transactions processing engine and are investigating. We apologise for any inconvenience this may cause and will keep you updated here.
Posted Jul 22, 2022 - 20:08 UTC
This incident affected: 💳 Transactions, 💰 Wallet, and Card.