Degraded performance
Incident Report for Pleo
Resolved
Pleo is fully operational again.
Posted Mar 06, 2024 - 12:36 UTC
Investigating
Pleo is currently experiencing a degraded performance. We are investigating the root cause.
Posted Mar 05, 2024 - 09:49 UTC