Wallet and card issues
Incident Report for Pleo
Resolved
A misconfiguration of our production environment lead to this outage. The situation has now been resolved. Thank you for your patience.
Posted Feb 27, 2020 - 18:54 UTC
Investigating
We are investigating an issue causing our card and wallet pages to be unavailable. We apologize for the downtime. Stay tuned here for updates!
Posted Feb 27, 2020 - 18:44 UTC
This incident affected: 📱 Mobile application.