Processor experiencing declined transactions
Resolved·Partial outage

This incident has been resolved.

Wed, Feb 10, 2021, 01:51 PM
(4 years ago)
·
Affected components
💳 Transactions
Card
Updates

Resolved

This incident has been resolved.

Wed, Feb 10, 2021, 01:51 PM

Investigating

Our payment processor is experiencing issues with processing transactions. As a result, some card transactions are being declined.We are actively working with the processor to resolve their issue with highest priority. We'll provide details as we learn more.

Wed, Feb 10, 2021, 01:33 PM(17 minutes earlier)
Powered by