Accounting 3rd party degraded performance (e-conomic integration)
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 6 days ago. Apr 16, 2019 - 22:46 CEST
Investigating
More information available here : https://status.e-conomic.com/
Posted 20 days ago. Apr 02, 2019 - 13:53 CEST
This incident affected: 🛠 Integrations (e-conomic).