Slow and Degraded Performance
Resolved·Degraded performance

This incident has been resolved.

Mon, Oct 3, 2022, 05:03 PM
(2 years ago)
·
Affected components
📱 Mobile application
Web application
Updates

Resolved

This incident has been resolved.

Mon, Oct 3, 2022, 05:03 PM

Identified

We have identified the issue and are working on a solution.

Mon, Oct 3, 2022, 02:06 PM(2 hours earlier)

Investigating

We are currently investigating some issues with our mobile and web app.You may experience slower responses and time-outs while navigating on the pleo mobile and web app.Sorry for the inconvenience.

Mon, Oct 3, 2022, 10:00 AM(4 hours earlier)
Powered by