Resolved
We're working on a long-term solution in the background
Monitoring
We're looking at implementing a more long-term solution. This seems to only affect a small subset of customer using these privacy plugins. With whitelisting pleo.io in the privacy plugin, the app should be functional until the long-term solution is in place.
Identified
We have identified that privacy plugins, specifically Privacy Badger, block some of the services we rely on since their last release. We're working on a more long-term solution, but there is a temporary workaround customers can use by whitelisting our pleo domain pleo.io in this (or similar) privacy plugin.