Intermittent service interuption
Resolved·Partial outage

Root cause has been identified and a fix has been deployed.

Mon, Jun 16, 2025, 09:39 AM
(2 weeks ago)
·
Affected components
📱 Mobile application
Web application
Updates

Resolved

Root cause has been identified and a fix has been deployed.

Mon, Jun 16, 2025, 09:39 AM

Monitoring

We have identified the issue and deployed a fix that seems to have mitigated the issue, but we are continuously monitoring.

Tue, Jun 10, 2025, 02:56 PM(5 days earlier)

Investigating

We are currently experiencing some intermittent service interruption which might be affecting both Pleo web and mobile apps. The team is currently investigating and have already started deploying a change to mitigate the issue.

Tue, Jun 10, 2025, 02:43 PM(12 minutes earlier)
Powered by