Slow webpage loads
Resolved

The issue caused by an integration creating duplicate tags is now resolved. Customers who previously reported performance issues have confirmed the improvement.

Thu, Jan 23, 2025, 09:27 AM
1 week ago
Affected components

No components marked as affected

Updates

Resolved

The issue caused by an integration creating duplicate tags is now resolved. Customers who previously reported performance issues have confirmed the improvement.

Thu, Jan 23, 2025, 09:27 AM
1 week earlier...

Investigating

We've had reports of slow performance from some users, we're actively investigating and will update as soon as we have further information

Fri, Jan 10, 2025, 02:12 PM
Powered by