Partner issues
Resolved·Full outage

All systems have returned to normal

Mon, Sep 23, 2019, 11:40 AM
(5 years ago)
·
Affected components
💳 Transactions
Updates

Resolved

All systems have returned to normal

Mon, Sep 23, 2019, 11:40 AM

Investigating

Our partner is experiencing issues. This affects transactions and may result in declines. We are doing what we can on our side to mitigate the issue.

Mon, Sep 23, 2019, 11:27 AM(13 minutes earlier)
Powered by