Unable to view virtual cards
Resolved·Partial outage

This incident has been resolved.

Sat, Apr 11, 2020, 09:07 AM
(5 years ago)
·
Affected components
Card
Updates

Resolved

This incident has been resolved.

Sat, Apr 11, 2020, 09:07 AM

Identified

We've concluded that the issue originates from a faulty API on our payment provider's side. We're waiting for their fix.

Sat, Apr 11, 2020, 08:25 AM(41 minutes earlier)

Investigating

It's currently not possible to view virtual card details. We're investigating the cause.

Sat, Apr 11, 2020, 06:21 AM(2 hours earlier)
Powered by