Internal processing issues
Resolved·Partial outage

This incident has been resolved.

Wed, Jan 13, 2021, 03:58 PM
(4 years ago)
·
Affected components
📱 Mobile application
⚙️ Pleo API
Updates

Resolved

This incident has been resolved.

Wed, Jan 13, 2021, 03:58 PM

Investigating

Data processing has slowed in some of our services, and export functionality may be impacted for some of our customers.

Wed, Jan 13, 2021, 03:08 PM(50 minutes earlier)
Powered by