Pleo web page blank
Resolved

This incident has been resolved.

Wed, Mar 17, 2021, 08:57 PM
(4 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Wed, Mar 17, 2021, 08:57 PM

Identified

There is currently an issue with Pleo's web page where it stays blank.There is also an issue getting the card details in the APP.The issue has been identified and we are working on a fix.

Wed, Mar 17, 2021, 08:33 PM(24 minutes earlier)

Identified

There is currently an issue with Pleo's web page where it stays blank. The issue has been identified and we are working on a fix.

Wed, Mar 17, 2021, 08:12 PM(21 minutes earlier)
Powered by