Transactions failing and card retrieval is unavailable
Resolved·Full outage

We have identified and resolved the issue with transactions and card retrievals.

Thu, Sep 30, 2021, 12:31 PM
(3 years ago)
·
Affected components
📱 Mobile application
Card
Updates

Resolved

We have identified and resolved the issue with transactions and card retrievals.

Thu, Sep 30, 2021, 12:31 PM

Investigating

We are continuing to investigate this issue.

Thu, Sep 30, 2021, 11:22 AM(1 hour earlier)

Investigating

Many users are reporting inability to retrieve card details in their mobile and web applications.

Thu, Sep 30, 2021, 11:16 AM
Powered by