Card information not visible
Resolved·Partial outage

It is now possible to view Pleo cards in the web and mobile applications again.

Mon, Mar 14, 2022, 08:54 PM
(3 years ago)
·
Affected components
Card
Updates

Resolved

It is now possible to view Pleo cards in the web and mobile applications again.

Mon, Mar 14, 2022, 08:54 PM

Identified

We have resolved the issue in the web application and continue to work on the mobile application.

Mon, Mar 14, 2022, 08:33 PM(21 minutes earlier)

Investigating

We have resolved the issue in the web application and continue to work on the mobile application.

Mon, Mar 14, 2022, 08:32 PM

Investigating

Some users are unable to see their Pleo cards in the web and mobile applications. We are investigating and will update as soon as possible.

Mon, Mar 14, 2022, 07:47 PM(45 minutes earlier)
Powered by