Reimbursements not available for employees on newest app version
Resolved·Partial outage

We've fixed the issue and employees should now be able to reimburse directly via the latest Pleo mobile app

Fri, Sep 8, 2023, 09:47 AM
(1 year ago)
·
Affected components
Reimbursements
Updates

Resolved

We've fixed the issue and employees should now be able to reimburse directly via the latest Pleo mobile app

Fri, Sep 8, 2023, 09:47 AM

Identified

We've spotted that something has gone wrong with Reimbursements for employees. We've found the issue and expect it to be solved shortly.

Fri, Sep 8, 2023, 09:14 AM(32 minutes earlier)
Powered by