Auto top-up functionalities are impacted for EUR customers
Resolved

The incident has been resolved

Tue, Feb 13, 2024, 01:54 PM
(1 year ago)
·
Affected components

No components marked as affected

Updates

Resolved

The incident has been resolved

Tue, Feb 13, 2024, 01:54 PM

Identified

The issue has been identified. Pleo recommends to perform manual top ups instead of relying on Auto Top-Ups.Pleo is currently in direct communication with their banking partners to fix this issue.

Mon, Feb 12, 2024, 12:28 PM(1 day earlier)

Investigating

We are experiencing several issues with Auto Top-Up functionalities. We are investigating the root cause.

Mon, Feb 12, 2024, 10:00 AM(2 hours earlier)
Powered by