Issues paying invoices
Resolved·Degraded performance

This is now resolved for customers.

Thu, Oct 24, 2024, 03:02 PM
(8 months ago)
·
Affected components
Invoices
Updates

Resolved

This is now resolved for customers.

Thu, Oct 24, 2024, 03:02 PM

Monitoring

We've corrected the error, and are busy monitoring the fix

Thu, Oct 24, 2024, 09:56 AM(5 hours earlier)

Monitoring

We believe the issue paying invoices is resolved, and are monitoring the situation.

Thu, Oct 24, 2024, 09:50 AM

Monitoring

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.

Thu, Oct 24, 2024, 09:48 AM

Investigating

We've spotted that something has gone wrong and some users are having difficulty paying invoices. We're investigating and hope to have it resolved soon.

Thu, Oct 24, 2024, 08:39 AM(1 hour earlier)
Powered by