Resolved
The issue has been solved, access to the Pleo web app has been restored.
Investigating
We are currently experiencing an issue preventing users from logging in to the Pleo web app. Our team is working with the highest priority to resolve this.
Customers should still be able to access the mobile app.
Investigating
We are currently experiencing an issue preventing users from logging in to the Pleo web app. Our team is working with the highest priority to resolve this.
Investigating
We are currently experiencing an issue preventing users from logging in to the Pleo web app. Our team is working with the highest priority to resolve this.