Resolved
We have resolved the issue that was preventing users from viewing their active cards in the web page. Cards are now displaying correctly for all users. We apologize for the inconvenience caused.
Identified
An issue is preventing some users from seeing their cards details and activating cards in the Pleo web app. Users can access card functionality in the mobile app. Our team is actively investigating and working on a fix.