The issue has been resolved
Resolved
Monitoring
We believe the issue is resolved, but are continuing to monitor the situation.
Identified
Some customers are unable to access the Invoices page. We have identified the issue and are working on a fix.