Invoice and reimbursement payments are degraded
Resolved·Degraded performance

A recent system change caused missing data in transfer requests, resulting in errors. After applying a fix, most outgoing payments were automatically reprocessed and sent.

Tue, Aug 5, 2025, 01:08 PM
(3 weeks ago)
·
Affected components
Reimbursements
Invoices
Updates

Resolved

A recent system change caused missing data in transfer requests, resulting in errors. After applying a fix, most outgoing payments were automatically reprocessed and sent.

Tue, Aug 5, 2025, 01:08 PM

Monitoring

The root cause has been resolved and the team is monitoring the systems performance. Payments for both invoices and reimbursements are back online.

Tue, Aug 5, 2025, 11:26 AM(1 hour earlier)

Monitoring

The root cause identified and addressed. The team is monitoring the fix. Further updates will come shortly.

Tue, Aug 5, 2025, 11:00 AM(26 minutes earlier)

Identified

Invoice and reimbursement payments are currently failing due to a technical issue and are temporarily disabled. The team has identified the issue and are actively working on a solution.

Tue, Aug 5, 2025, 09:59 AM(1 hour earlier)
Powered by