Mobile receipt upload is not working for some customers
Resolved·Degraded performance

We’ve identified and fixed the issue that was causing some mobile receipt uploads to fail. Everything should now be working as expected

Wed, Jul 30, 2025, 04:24 PM
(1 month ago)
·
Affected components
📱 Mobile application
Updates

Resolved

We’ve identified and fixed the issue that was causing some mobile receipt uploads to fail. Everything should now be working as expected

Wed, Jul 30, 2025, 04:24 PM

Investigating

We see that some customer experience this issue and are still investigating the root cause

Wed, Jul 30, 2025, 01:09 PM(3 hours earlier)

Investigating

In some instances we see that mobile receipt upload is failing, we're actively investigating the issue

Wed, Jul 30, 2025, 08:32 AM(4 hours earlier)
Powered by