Mobile and Web access unavailable
Resolved·Partial outage

Both Mobile and Web access are now back online. Users should be able to use Pleo as expected.

Tue, Jun 17, 2025, 02:29 PM
(2 months ago)
·
Affected components
📱 Mobile application
Web application
Updates

Resolved

Both Mobile and Web access are now back online. Users should be able to use Pleo as expected.

Tue, Jun 17, 2025, 02:29 PM

Investigating

We are currently experiencing a major service interruption affecting both our mobile and web applications. Users may encounter a "Something went wrong" error message, and content is not loading on either platform.

Tue, Jun 17, 2025, 01:53 PM(35 minutes earlier)
Powered by