Error viewing expenses on the export and invoices pages
Resolved

We have received customer reports that this issue has been resolved.

Wed, Jun 4, 2025, 03:47 PM
(2 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

We have received customer reports that this issue has been resolved.

Wed, Jun 4, 2025, 03:47 PM

Resolved

We have received customer report that this issue has been resolved.

Wed, Jun 4, 2025, 02:48 PM(58 minutes earlier)

Monitoring

We have released a fix, which is now rolling out on our servers. Customers with issues should no longer see the issue, and should refresh their browser if the issue persists in their app.

Wed, Jun 4, 2025, 01:26 PM(1 hour earlier)

Identified

We have identified the issue and are rolling out a fix

Wed, Jun 4, 2025, 12:37 PM(49 minutes earlier)

Investigating

Recent expenses may fail to be shown, but can still be exported

Wed, Jun 4, 2025, 12:32 PM
Powered by