Mastercard network issues
Incident Report for Pleo
Resolved
It seems that the issues have largely subsided. We'll continue monitoring and update the status accordingly if anything changes. Sorry for the inconvenience.
Posted about 1 year ago. Jun 12, 2018 - 13:48 CEST
Investigating
Mastercard network is currently experiencing issues that are affecting a certain percentage of transactions. Declines are possible. We're monitoring the situation and will keep you updated.
Posted about 1 year ago. Jun 12, 2018 - 11:19 CEST
This incident affected: 💳 Transactions.