Transaction partner issues
Incident Report for Pleo
Resolved
The incident has been resolved.
Posted Aug 02, 2019 - 12:50 CEST
Identified
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.

We suggest carrying a second card or retrying the transaction if it fails.

Thanks for your understanding.
Posted Aug 02, 2019 - 12:37 CEST
This incident affected: 💳 Transactions.