Transaction partner issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Aug 12, 2019 - 14:24 CEST
Update
We are continuing to work on a fix for this issue.
Posted Aug 12, 2019 - 13:53 CEST
Identified
Our transaction partner is experiencing issues.

We suggest carrying a second card or retrying the transaction if it fails.

Thanks for your understanding.
Posted Aug 12, 2019 - 13:50 CEST
This incident affected: 💳 Transactions.