Transaction partner issues
Incident Report for Pleo
Resolved
Our partner is processing normally again and the issue should be resolved.
Posted May 23, 2019 - 12:16 CEST
Investigating
Our transaction partner is experiencing issues.

This may affect transactions, loading money and viewing your card.

We suggest carrying a second card or retrying the transaction if it fails.

Thanks for your understanding.
Posted May 23, 2019 - 10:43 CEST
This incident affected: 💳 Transactions and 💰 Wallet.