Working with some acquirers on transaction issues
Incident Report for Pleo
Resolved
This incident is now resolved. It appears to have been related to an issue at Mastercard regarding their SecureCode infrastructure. Please let us know if you are still experiencing issues.
Posted about 1 year ago. Mar 02, 2018 - 19:06 CET
Investigating
We are investigating transactions issues with certain merchants. We will update as soon as we have more information.
Posted about 1 year ago. Mar 02, 2018 - 15:11 CET