Payment Processor Downtime
Incident Report for Pleo
Resolved
Our payment processor confirmed the resolution of the issue. Thank you for your patience. Please reach out to our support if you are experiencing any more issues.
Posted 5 months ago. Oct 23, 2018 - 06:11 CEST
Update
We are continuing to monitor for any further issues.
Posted 5 months ago. Oct 23, 2018 - 05:53 CEST
Monitoring
We are seeing transaction coming in again, but we are waiting for the confirmation from the payment processor. We will be monitoring the situation.
Posted 5 months ago. Oct 23, 2018 - 05:52 CEST
Update
We have received communication that our payment processor has found the root cause of the issue and are currently working in bringing the system online. We are expecting a recovery within the next half hour.
Posted 5 months ago. Oct 23, 2018 - 05:36 CEST
Update
Our payment processor is investigating this incident in top priority. We will keep you updated as new information arrives.
Posted 5 months ago. Oct 23, 2018 - 04:42 CEST
Identified
Our third-party payment processor is currently experiencing difficulties. We are in contact with their operations team in order to reinstate the service as soon as possible.
Posted 5 months ago. Oct 23, 2018 - 03:50 CEST
This incident affected: 💳 Transactions and 💰 Wallet.