Issues with card related features
Incident Report for Pleo
Resolved
All services have been returned to normal functionality
Posted Oct 15, 2021 - 14:16 UTC
Investigating
We are experiencing issues with our non payment but card related features. This includes viewing PIN and card details. We are actively working to resolve the issue. Card transactions should not be affected.
Posted Oct 15, 2021 - 12:43 UTC
This incident affected: 📱 Mobile application and Card.