Third-party timeouts in service response
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 10 months ago. Aug 21, 2018 - 20:50 CEST
Identified
We're experiencing timeouts while displaying virtual cards & getting PIN. Our third party payment processor is investigating this issue. Wallet loads will also be delayed.
Posted 10 months ago. Aug 21, 2018 - 19:53 CEST
This incident affected: 💰 Wallet.