Cards and wallet issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Jun 21, 2019 - 19:18 CEST
Update
We have fixed the issue and will continue monitoring.
Posted Jun 21, 2019 - 19:18 CEST
Update
We are continuing to work on a fix for this issue.
Posted Jun 21, 2019 - 19:17 CEST
Identified
We are experiencing an issue with our card and wallet processing. Our team is investigating, more information to come. We apologize for the inconvenience.
Posted Jun 21, 2019 - 19:02 CEST
This incident affected: 💰 Wallet and Card.