Product website and some app functions have issues loading
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 15 days ago. Sep 02, 2019 - 16:20 CEST
Update
We are continuing to investigate this issue.
Posted 15 days ago. Sep 02, 2019 - 13:59 CEST
Update
The application is now responsive and we are monitoring our systems
Posted 15 days ago. Sep 02, 2019 - 13:48 CEST
Investigating
Our product page app.pleo.io is currently having issues loading. We're looking into it.

We're sorry for the trouble.
Posted 15 days ago. Sep 02, 2019 - 13:11 CEST
This incident affected: 📱 Application.