Transaction partner issues
Incident Report for Pleo
Resolved
The issue has been resolved. We will keep monitoring. We apologize for this incident.
Posted Jan 02, 2020 - 23:28 CET
Identified
Our transaction partner is experiencing issues. Retrieving wallet balances might fail.
Posted Jan 02, 2020 - 23:25 CET
This incident affected: 💰 Wallet.