UK sign-up partial outage
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 14, 2018 - 13:35 CET
Monitoring
Companies House is back online. We continue to monitor the situation and will resolve after a few minutes.
Posted 5 months ago. Feb 14, 2018 - 13:23 CET
Investigating
Companies House is currently experiencing difficulties. Our automatic on-boarding relies on this partner to retrieve your company information.
We are monitoring the situation and will update as soon as possible.
Posted 5 months ago. Feb 14, 2018 - 13:04 CET