Help page unavailable
Incident Report for Pleo
Resolved
help.pleo.io is operational again!

Thank you for your patience.
Posted about 1 year ago. Sep 25, 2017 - 11:20 CEST
Investigating
We have noticed our help.pleo.io page is currently unavailable because our external partner is having issues. We're monitoring the situation and will provide further updates if necessary.

Sorry for the inconvenience.
Posted about 1 year ago. Sep 25, 2017 - 10:47 CEST