Transaction partner issues
Incident Report for Pleo
Resolved
The issue has now been resolved.
Posted 12 months ago. Nov 02, 2017 - 23:03 CET
Identified
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.
Posted 12 months ago. Nov 02, 2017 - 22:17 CET