Transaction partner issues
Incident Report for Pleo
Resolved
Our transaction partner is now processing normally.
Posted 6 months ago. Apr 05, 2018 - 15:56 CEST
Identified
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.
Posted 6 months ago. Apr 05, 2018 - 15:45 CEST