Slow pages responses
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 10 months ago. Feb 06, 2018 - 16:11 CET
Identified
We have identified performance issues with multiple pages in the application.
Posted 10 months ago. Feb 06, 2018 - 15:47 CET
Investigating
The "Teams" page is unavailable or responding slowly at the moment. We are investigating the issue.
Posted 10 months ago. Feb 06, 2018 - 14:25 CET
Monitoring
Issue has been resolved, we are actively monitoring the issue.
Posted 10 months ago. Feb 06, 2018 - 14:21 CET
Investigating
The "Teams" page is unavailable at the moment. We are investigating the issue.
Posted 10 months ago. Feb 06, 2018 - 14:03 CET