Transaction partner issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 8 months ago. Nov 03, 2017 - 17:26 CET
Investigating
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.
Posted 8 months ago. Nov 03, 2017 - 16:03 CET