Web application unavailable.
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 11, 2018 - 21:33 CEST
Update
Web application is now fully operational.
Posted 3 months ago. Apr 11, 2018 - 18:34 CEST
Identified
The web application is currently unavailable. We've identified the issue. Issue will be resolved soon.
Posted 3 months ago. Apr 11, 2018 - 18:25 CEST